River failures for Netsuite RESTlet using customsearch
Incident Report for Rivery
Resolved
After additional monitoring, we see that the rivers are successfully running. We are marking this incident as resolved.

Please note that the incident impacted both the the US console (https://console.rivery.io/) and EU console (https://eu-west-1.console.rivery.io/) between 08-10-2024 at 8:30 UTC and 09-10-2024 at 16:30 UTC.

Rivers will run normally on the next scheduled runs and capture data from the previous successful river run.

Thank you for your patience while we resolved the issue. If you continue to experience any issues or need assistance from our team, please open up a ticket in the console via Help --> Contact Support and our support team will be happy to help you.
Posted Oct 09, 2024 - 18:39 UTC
Monitoring
We have deployed a fix to address the Netsuite RESTlet errors for customsearch river runs. Rivers will run normally on the next scheduled runs and capture data from the previous successful river run.

We are monitoring the rivers for any issues.

If you continue to experience any issues or need assistance from our team, please open up a ticket in the console via Help --> Contact Support and our support team will be happy to help you.
Posted Oct 09, 2024 - 16:35 UTC
Identified
We’re seeing an increase in errors for rivers using Netsuite RESTlet as a source where customsearch data fails to fetch.

The error shown is: "Couldn\'t read customsearch" AND "Please check your access and roles. Error: HTTPSConnectionPool" AND
"restlets.api.netsuite.com\', port=443): Read timed out. (read timeout=30)"

We have identified the root cause for the issue and will provide updates on the resolution.
Posted Oct 09, 2024 - 15:32 UTC
This incident affected: Sources (NetSuite RESTlets).