Delayed Execution Times and Rivers in Pending Status - US console
Incident Report for Rivery
Resolved
This incident has been resolved.
Posted Nov 09, 2024 - 13:27 UTC
Monitoring
We have identified the root cause of the delayed execution times and pending status for Rivers, and a fix has been deployed.
The majority of existing runs are now expected to complete successfully.

Please note:
A small number of Rivers may continue to display as "running" until they timeout naturally.
There is no expected data loss; any Rivers that did not execute during this period will pick up the data in their next scheduled run.

We are continuing to monitor the system closely to ensure stable operation.
Thank you for your patience, and please reach out if you have any questions.

Rivery Support Team
Posted Nov 09, 2024 - 12:50 UTC
Identified
The issue has been identified and we are working to resolve the issue
Posted Nov 09, 2024 - 12:24 UTC
Monitoring
We have identified the root cause of the delayed execution times and pending status for Rivers
We are still working to resolve the issue and will update once a fix is implemented
Posted Nov 09, 2024 - 11:22 UTC
Identified
We are currently experiencing delays with River execution times and an increase in Rivers remaining in a pending status. Our team is actively investigating the issue to identify the root cause and restore optimal performance as quickly as possible.

During this time, you may notice that:
River executions are taking longer than usual to complete.
Some Rivers may remain in a pending status for extended periods.
We apologize for the inconvenience and appreciate your patience as we work to resolve this. Updates will be provided here as we make progress.


Thank you for your understanding.
Rivery Support Team
Posted Nov 09, 2024 - 10:40 UTC
This incident affected: Rivery Pipelines (Rivers (US)) and Rivery Console (console.rivery.io).