CDC rivers are failing with 'NoneType' object error

Incident Report for Rivery

Resolved

This incident has been resolved.
Posted Sep 04, 2024 - 11:10 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 04, 2024 - 10:39 UTC

Monitoring

We have identified an issue where CDC rivers encountered a `'NoneType' object has no attribute 'get'` error during execution.

Incident Time:
The impact occurred between 09:08 UTC and 10:39 UTC.

Current Status:
The error has been reverted in all affected regions.
The next scheduled runs of the rivers will catch any missed streamed data, ensuring no data loss.
There is no need to manually re-run failed rivers as future executions will pick up the data.

Next Steps:
We are actively investigating the root cause to understand what triggered this issue, even though the solution was previously tested thoroughly.

Our team is monitoring the situation closely to ensure smooth operation going forward.
We will provide further updates as more information becomes available.

Thank you
Rivery Support Team
Posted Sep 04, 2024 - 09:08 UTC
This incident affected: Rivery Pipelines (CDC (US), CDC (EU)).