Intermittent Data Push Failures for Snowflake Connections Using Private Key Authentication
Incident Report for Rivery
Resolved
This incident has been resolved.
Posted Nov 12, 2024 - 09:21 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 12, 2024 - 08:29 UTC
Monitoring
We experienced sporadic failures with Rivery when pushing data to Snowflake. This issue impacted a limited subset of our users—specifically those using private key authentication (key pair) to connect to Snowflake.

The failures were inconsistent and only affected certain tables at random.

Our team has identified the root cause, implemented a fix, and is actively monitoring the situation to ensure stability.
We apologize for any disruptions this may have caused and appreciate your patience.

If you continue to experience issues, please contact our support team.
Thank you for your understanding and trust in Rivery.
Posted Nov 12, 2024 - 08:29 UTC
This incident affected: Rivery Pipelines (Rivers (US)) and Targets (Snowflake).