Bing Ads - River Failures
Incident Report for Rivery
Resolved
This issue has been resolved and rivers with Bing Ads are now running successfully.

Please reach out to the Rivery Support Team (in the console via Help —> Contact Support) if you encounter any further issues.
Posted May 17, 2024 - 20:49 UTC
Monitoring
A fix to resolve the Bing Ads river failures was deployed at 18:31 UTC today and we have seen river activity return to normal.

Any data that was not transmitted during this outage will be captured during the next scheduled run.

We are actively monitoring the results and thank you for your patience as we worked to resolve this issue.
Posted May 17, 2024 - 19:38 UTC
Identified
We have identified the issue and are currently working on deploying a fix.

We will update once the fix has been deployed.
Posted May 17, 2024 - 17:07 UTC
Investigating
We are investigating an increase in failures with rivers where Bing Ads is the source, as many runs are returning the below error.

However, manually triggering a Source-to-Target (S2T) river with the Bing Ads integration functions correctly.

"No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/home/riverfw']"

We are actively looking into this and will follow up with additional details as soon as they are available.
Posted May 17, 2024 - 15:25 UTC
This incident affected: Rivery Pipelines (Rivers (US)) and Sources (Microsoft Bing Ads).