Redshift as Target - Failed to upload the data to Redshift
Incident Report for Rivery
Resolved
Some Rivers using Redshift as the target experienced failures with the error: "Failed to upload the data to Redshift."

Impact:
A small number of customers were affected.

Cause:
During a recent update aimed at enhancing error detection and troubleshooting for Redshift operations, an unexpected permissions issue occurred, which disrupted some Rivers' ability to complete data uploads.

Timeline:
Start: December 3rd, 15:00 UTC
Resolved: December 4th, 11:00 UTC (following a code rollback)

Resolution:
The issue has been resolved, and all impacted Rivers should now operate as expected.

Next Steps:
We are reviewing our processes to prevent similar occurrences in the future.
Please feel free to reach out to our support team if you have any further questions or concerns.

Thank you for your understanding and patience as we work to continuously improve our platform.
Rivery Support Team
Posted Dec 03, 2024 - 09:00 UTC