Instagram Source Failures in US and EU Consoles

Incident Report for Rivery

Monitoring

Our engineering team has successfully removed the deprecated Instagram metrics from impacted rivers to ensure the pipelines continue running smoothly. Customers who were using the impacted metrics will receive an email from the Rivery Product Team with clear action steps once the updates to support the new Instagram metrics are finalized. Thank you for your patience as we worked to resolve this issue.
Posted Apr 22, 2025 - 18:28 UTC

Identified

Starting April 21, 2025, we are observing failures in source-to-target river connections involving Instagram data sources across both the US and EU regions. These disruptions were caused by changes in the Instagram API.

Root cause:
Instagram’s API (version 21+) has deprecated certain time series metrics - see more information on the metrics here: https://developers.facebook.com/docs/instagram-platform/reference/instagram-media/insights

Insights data handling error: Instagram API original error: '(#100) Starting from version v22.0 and above, the impressions metric is no longer supported for the queried media. Please refer to the documentation at https://developers.facebook.com/docs/instagram-api/reference/ig-media/insights for a list of supported metrics. '.

Workaround:
To restore functionality and maintain continuity in reporting:
The deprecated impressions metric have to be replaced with the supported read metric in all affected pipelines.


We are currently active working on a fix including for the predefined reports and will update when deployed.
Posted Apr 22, 2025 - 14:03 UTC
This incident affects: Sources (Instagram Social).