Apple Search Ads Connector Issue

Incident Report for Rivery

Resolved

This incident has been resolved.
Posted Jan 30, 2025 - 15:20 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 29, 2025 - 10:34 UTC

Investigating

Starting January 28, 2025 at 01:00 PM (GMT)
Users with scheduled Rivers using outdated groupby fields are experiencing errors. The issue is impacting multiple clients, particularly in the US and EU regions.

Following the recent Apple Search Ads Connector upgrade from version 4 to version 5, we have identified an issue affecting scheduled Rivers using outdated field values. The error observed is:

'str' object has no attribute 'get'

This issue arises due to a change in the field type for group by fields, which were converted to a multi-select type. Scheduled Rivers are still sending old string values, causing data processing failures.
Posted Jan 29, 2025 - 09:00 UTC
This incident affected: Sources (Apple Search Ads).