Following continued monitoring, we can confirm that as of 09:10 UTC, all rivers have resumed normal functionality and are operating as expected.
We apologize for any inconvenience this may have caused and appreciate your patience.
If you continue to experience any issues, please don’t hesitate to contact our support team.
Posted Apr 17, 2025 - 17:46 UTC
Monitoring
On April 17, 2025, at 08:30 UTC, a planned instance maintenance window inadvertently caused the termination of active tasks. This affected river runs in both Prod-US and Prod-EU environments between 08:30–09:10 UTC, resulting in tasks being terminated mid-run.Although these tasks still appear as “Running” in the UI, they are not actually executing. Task executions initiated after 09:10 UTC have resumed normal functionality and are running as expected.
Impact: - Tasks scheduled between 08:30–09:10 UTC were unexpectedly terminated. - Affected runs remain inaccurately displayed as “Running” in the UI. - No impact on task executions beyond 09:10 UTC.
Next steps: - The next scheduled river runs will resume from the start date of the last successful execution. - Engineering is reviewing monitoring and UI accuracy enhancements to prevent recurrence.
Posted Apr 17, 2025 - 15:24 UTC
This incident affected: Rivery Console (console.rivery.io, eu-west-1.console.rivery.io).