Our engineering team has corrected the issue and Pinterest Ads Delivery Report rivers is operating as expected.
Posted Oct 23, 2025 - 12:08 UTC
Monitoring
Our engineering team implemented corrective actions to resolve the issues with the Pinterest Ads Delivery Report rivers. We will continue to monitor the services for stability for the next 1 hour.
Posted Oct 23, 2025 - 10:57 UTC
Update
We have identified the cause of the degraded performance you may have experienced. Our engineering team is working to resolve the issue and we will provide an update once the issue is resolved. We apologize for any inconvenience this incident may have caused
Posted Oct 23, 2025 - 10:43 UTC
Identified
We are currently investigating an issue affecting Pinterest integrations where some users may encounter errors when connecting to or retrieving data from the Pinterest API. Our engineering team is actively investigating and working with Pinterest to identify the root cause. We will share further updates as soon as they become available.