Apple Appstore Connect: Apps Analytics Rivers are failing "Please contact Rivery Support"

Incident Report for Rivery

Resolved

The incident has been resolved.
The App Store Connect Analytics connector has been successfully redesigned, developed, and deployed in production.
Customers are now required to take action to reconnect using the new connection flow.

Summary of Work Done:
- Cause of the Issue: Apple introduced significant changes to its authentication flow, including the implementation of the SRP (Secure Remote Password) protocol. This deprecated the previous login flow, rendering existing connections unusable.
- Solution Implemented: A brand-new connector was developed to comply with Apple’s new authentication and data retrieval requirements.
The new flow leverages JWT-based token authentication and adheres to the updated App Store Connect API specifications.
The new connector allows users to request and download a wide variety of 12 pre-defined reports (e.g., App Downloads, Purchases, Pre-orders, App Sessions, etc.).

Testing & Validation:
- Extensive end-to-end (E2E) testing was conducted to ensure stability and compatibility.
- Documentation was updated to reflect the new process and reports available.
- Deployment: The new connector is now live and ready for customer use.

We encourage customers to refer to the updated documentation to follow the new setup process -
https://docs.rivery.io/v1/docs/app-store-connect-apps-analytics


We Thank you for your patience - please contact Rivery support for any questions or assistance you may need.
Posted Jan 08, 2025 - 10:12 UTC

Identified

We are currently facing an issue where Apple Appstore Connect: Apps Analytics Rivers are failing with the error message "Please contact Rivery Support."

This issue has occurred due to an unexpected change Apple implemented in their API.
Our R&D team is actively working on a solution, and we will provide updates as soon as the fix is deployed.

We apologize for any inconvenience this may cause and appreciate your patience.
Please don’t hesitate to reach out if you have any questions.

Best regards,
Rivery Support Team
Posted Oct 21, 2024 - 15:15 UTC
This incident affected: Sources (Apple Appstore Connect: Apps Analytics).