502 Errors for Google Analytics Source to Target Rivers

Incident Report for Rivery

Resolved

After deploying our recent fix and closely monitoring the system, we are pleased to report that all errors related to Google Analytics have been resolved.

All systems are functional and operating normally.

Thank you for your patience while we addressed this issue, for any inquiries please reach out to our Rivery Support Team.
Posted Apr 24, 2025 - 16:16 UTC

Monitoring

We deployed a fix at 24/04/2025 | 14:24:42 UTC. Google recently removed access to a discovery URL that our system used to initiate Universal Analytics (UA) reports.GA4 reports are fully functional and not impacted.

To address the issue for the users still using UA, we’ve made a targeted change in our system.

If you're still using UA, we strongly encourage switching to GA4 reports.
We’re continuing to monitor the process on our side to ensure everything runs smoothly.
Posted Apr 24, 2025 - 14:23 UTC

Identified

We have identified the issue and our team is actively working on a fix. We are committed to resolving this as quickly as possible and will provide updates as we make progress.

Thank you for your patience.
Posted Apr 24, 2025 - 13:53 UTC

Monitoring

The 502 error appears to originate from the Google Analytics API endpoint.
At this time, we believe the issue is external and related to a service disruption on Google’s side.

Data rivers are currently running and we are closely monitoring for any further anomalies or disruptions.
Posted Apr 23, 2025 - 17:32 UTC

Investigating

Starting April 23, 2025, at 08:00 UTC, we see an issue affecting source-to-target data rivers connected to Google Analytics. Users may encounter failures with the following error message:

"Failed to establish connection to Google Analytics: ".

This appears to be caused by a response from the Google Analytics API.

We are currently investigating the root cause and will provide updates as more information becomes available.
Posted Apr 23, 2025 - 14:43 UTC
This incident affected: Sources (Google Analytics).