Connection Error when using Pair Authentication

Incident Report for Rivery

Resolved

This incident has been resolved.
Posted Oct 09, 2023 - 13:06 UTC

Monitoring

Our team deployed a fix late last week to resolve the connection issues with Key Pair authentication. We are continuing to monitor the resolution.
Posted Oct 03, 2023 - 12:33 UTC

Update

Our team has identified that connection errors are also occurring at times in rivers where BigQuery is a target. The following error may occur "Google Cloud connection error. Please check your project settings, service account and credentials files."

We are continuing to investigate and work on a resolution for these issues. Thank you for your patience and understanding.
Posted Sep 25, 2023 - 16:06 UTC

Identified

Customers who are using Snowflake with key pair authentication may be experiencing the following error: "Connection to Snowflake failed. Please check your credentials, your warehouse permissions and your account preferences in Snowflake."

As a temporary workaround, switching the Authentication Type from "Key Pair" to "Basic" in your Snowflake Connection settings should prevent the errors from occurring.

Our team is actively working on a solution. Thank you for your patience as we work to resolve this issue.
Posted Sep 21, 2023 - 18:07 UTC
This incident affected: Targets (Google BigQuery, Snowflake).