Google Ads Rivers Failing (long run durations)

Incident Report for Rivery

Resolved

This incident has been resolved.
Posted Aug 06, 2025 - 10:50 UTC

Monitoring

A fix has been deployed to address the issue affecting multiple Google Ads rivers that were failing due to custom timeouts.
We are currently monitoring the system to ensure stability and to confirm that all affected rivers are running as expected.
Posted Aug 06, 2025 - 08:30 UTC

Investigating

We’ve identified that certain Google Ads reports – such as Click_View and Ad Group Ad – are taking longer to run than expected. As a result, some rivers are failing due to exceeding the timeout values configured by the customer.

Our team is currently investigating the root cause and will provide updates as soon as possible.
Posted Aug 06, 2025 - 07:15 UTC
This incident affected: Rivery Console (console.rivery.io, eu-west-1.console.rivery.io) and Sources (Google Ads).